Users are reporting slowness and general delays
Incident Report for SocialBoards
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2022 - 11:50 CEST
Investigating
Some users are reporting system slowness. We're investigating the issue.
Posted May 19, 2022 - 14:47 CEST