Short update to the servers
Incident Report for SocialBoards
Resolved
Update complete - Your inbox should work as normal.
Posted Feb 06, 2019 - 15:33 CET
Identified
We're making a few adjustments which might cause your inbox to become offline for a few minutes.
Posted Feb 06, 2019 - 15:29 CET
This incident affected: Inbox.