Slowness Issues
Incident Report for SocialBoards
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 16:48 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2023 - 14:22 CET
Identified
We're aware of slowness issues and are actively troubleshooting. Thanks for your patience as we work to resolve this promptly.
Posted Dec 15, 2023 - 14:10 CET
This incident affected: Inbox.