Socialboards Inbox does not load
Incident Report for SocialBoards
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 25, 2019 - 13:28 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 23 days ago. Sep 25, 2019 - 10:03 CEST
Investigating
We are currently investigating this issue.
Posted 23 days ago. Sep 25, 2019 - 09:55 CEST
This incident affected: Inbox.