Inbox not loading properly
Incident Report for SocialBoards
Resolved
This incident has been resolved.
Posted Apr 09, 2019 - 09:30 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2019 - 09:03 CEST
Investigating
Inbox doesn't load properly. We are looking in to this issue
Posted Apr 09, 2019 - 09:01 CEST
This incident affected: Inbox.