Website out of service
Incident Report for SocialBoards
Resolved
This incident has been resolved.
Posted Nov 09, 2021 - 13:51 CET
Investigating
Some clients report that they can't reach our website. To log in to your Socialboards account, please go directly to https://login.socialboards.com/
Posted Nov 09, 2021 - 12:48 CET
This incident affected: Website.