Small lag reported
Incident Report for SocialBoards
Resolved
This incident has been resolved.
Posted Feb 08, 2019 - 15:07 CET
Investigating
Some clients have reported some lag in their inboxes. We're investigating the issue.
Posted Feb 08, 2019 - 10:36 CET
This incident affected: Inbox.