Quick update of our servers at 16:00
Incident Report for SocialBoards
Resolved
Your inbox is back to normal :)
Posted Feb 15, 2019 - 16:12 CET
Investigating
We're publishing a few improvements to the Chat module at 16:00 CET today. Your Socialboards inbox might become slow for a few minutes.
Posted Feb 15, 2019 - 15:51 CET
This incident affected: Inbox.